Widespread cloud provider outages

Incident Report for PredictIt

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 19:44 EDT

Monitoring

Cloud services have recovered and we are actively monitoring.
Posted Oct 29, 2025 - 18:45 EDT

Identified

Due to widespread outages with cloud services, users may experience issues while using predictit.org. We are investigating this issue.
Posted Oct 29, 2025 - 13:22 EDT
This incident affected: Web App.